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How to Make Color-By-Number Quizzes in 
Microsoft Excel 
Step One: Choose the Artwork You’d Like to Make 

• Excel spreadsheets are rectilinear, which lends itself well to the kind of pixel art you find in 

vintage video games. 

• Choose a simple image to start with until you get the hang of the process. This tutorial uses the 

image of a ‘Goomba’ from the video game Super Mario Bros. There are only three colors in the 

image, occupying a 17x17 grid. 

 

Step Two: Prep Your Excel Template 
• Launch Excel and start a blank workbook. 

• Go to File > Options > Formulas > Error Checking Rules and uncheck “Formulas inconsistent with 

other formulas in the region”, otherwise you will get unsightly little green triangles in the 

corners of the cells in your image. Click ‘OK’. 

• On the View tab, Workbook Views group, select ‘Page Layout’. This changes the dimensions of 

your row height and column width to inches, which can make it easier to make your cells 

square. You can do it in Normal view too, but the units of measure for rows and columns are 

different, which can be confusing. 

• Click anywhere in the body of the spreadsheet and type CTRL+A to select all rows and cells. 

• RIGHT-CLICK on any column header and choose ‘Column Width’. Set this value to 0.25”.  

• RIGHT-CLICK on any row header and choose ‘Row Height’. Set this value to 0.25”. 

• Now all your cells are square! If you find later that your image is so large it is filling up too much 

of the page, you can set these values lower to make your ‘pixels’ smaller. 

• If you plan to print out your artwork, leave your workbook in Page Layout view. You will 

probably want to switch to Landscape orientation so everything prints on one page. Go to the 

Page Layout tab > Page Setup group > Orientation, and select ‘Landscape’. 

• Otherwise, switching back to Normal view can give you more screen real estate to work with. 

Just go back to the View tab > Workbook Views group and choose ‘Normal’. 

Step Three: Outline the Image Area (Optional) 
• NOTE: This step is optional, but I find it helps me when I am defining the Conditional Formatting 

in Step Six, and it looks nice. 
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• Decide where on your sheet you would like the image to be. I usually put mine in the upper left 

corner of my template, beginning in cell B2. That leaves a margin of one row and one column 

around. 

• Use your mouse to highlight the space your image will occupy. I like to leave a little margin 

around the image, so for this tutorial we will highlight an area 18 columns wide by 18 rows high 

(cells B2:S19). 

• On the Home tab > Font Group, open the Borders dropdown and choose ‘Thick Box Border’. 

Now we have a nice outline around the image area.  

 

Step Four: Note the RGB Values of Image Colors (Optional) 
• NOTE: this step is only necessary if you want the colors of your image to exactly match the 

artwork you are reproducing. If you are going to select your own colors, you can skip this step. 

• To define a specific color in Excel, you will need the Red/Green/Blue (RGB) or 

Hue/Saturation/Lightness (HSL) values of each color. 

• Open your image in the editing software of your choice. I use MS Paint in this tutorial because it 

ships free with Windows and is very simple to use, but the process is very similar in many other 

image editors. Paint.net and PicPick are other simple-to-use and free tools you can find online. If 

you use PicPick, you will need to convert Hex to RGB. (I really like www.webpagefx.com/web-

design/hex-to-rgb/ for this, but there are many utilities available online. You can Google 

‘convert Hex to RGB’ for options). 

• In MS Paint: 

o Go to the Home tab > Tools group and select the Eyedropper tool. 

o Click anywhere in a colored region. This ‘picks out’ the color you clicked on. 

o Go to the Home tab > Colors group and click ‘Edit Colors’. 

https://www.webpagefx.com/web-design/hex-to-rgb/
https://www.webpagefx.com/web-design/hex-to-rgb/
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o Note the values defined for Red, Green, and Blue. Paint also provides Hue, Saturation, 

and Lightness. Excel will accept either set of values if you change the color model. In 

Step Six, we’ll talk about how to do this. 

o Repeat for each color in your image. 

Step Five: Define Your Quiz Questions and Answers 
• You will need one question for each image in your template, plus an extra one for a background 

color. Questions can be multiple-choice or not, but they cannot have subjective answers. 

• In the blank cells adjacent to your image outline, type your questions. 

• On the Home tab > Font Group, open the Borders dropdown and choose ‘Thick Bottom Border’ 

or ‘All Borders’ to define where you want your user to type their answer. 

• Use whatever formatting you like to make your question and answer sections distinctive. I 

generally use some or all the following: 

o Highlight multiple cells around your ‘Questions’ and ‘Answers’ headings. Go to Home > 

Alignment group > Merge & Center 

o Go to Home > Font group and apply bold, underline, or alternate fonts. 

o Go to Home > Styles group > Titles & Headings and apply styles. 

o Go to View > Show and uncheck ‘Gridlines’ (but wait to do this until the very end; the 

gridlines are helpful for making your pixel art). 

• Finally, fill in the correct answers for each of your questions. This will help when we define the 

Conditional Formatting in the next step. 
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Step Six: Apply Conditional Formatting 
• For the workbook to be interactive, we need to apply conditional formatting to the image area. 

That way when your user enters the correct answer to the quiz question, the cells automatically 

change color. 

• There are two ways to do this, each yielding a different visual result. 

o Method #1 (Traditional) gives you a more traditional color-by-number appearance, 

where each cell contains the answer to the question. This works equally well for 

arithmetic quizzes (where the cells display a number) and multiple choice (where the 

cells will display the letter choice). 

o Method #2 (Clean) gives a cleaner image, without the answers in-cell. 

 

Method #1 (Traditional) 
• Start by filling in the correct answers to all the questions so you can see the results of your 

formatting work as you go. 

• Note the column and row where your student will type the answer to Question #1. In our 

example, the answer to goes in column Z, row 4. 

• Click into the upper left cell of your image area (in our example, cell B2). Type =$Z$4. The dollar 

signs are very important, as you will see in a moment. 

• Now when you hit the ENTER key or click out of B2, you’ll see it displaying the contents of cell 

Z4. Click back into B2. See the little green square in the lower left corner of the cell? That’s your 

Fill Handle. 

• Click the Fill Handle and drag down to the last cell in row B inside your image boundary. When 

you stop dragging, you will see a little dropdown box near your cursor. Open the dropdown and 

select ‘Fill without Formatting’. This is important, otherwise Excel will bring along the border. 

 

Method 2- Traditional (Answers In-Cell) Method 1 - Clean (No Answers In-Cell) 
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• Continue using the Fill Handle this way until you have some of your background filled out. You 

can use the Fill Handle in any direction and even overwrite existing data with it. Remember to 

use ‘Fill without Formatting’ if you start at the edge of your image. 

• Now let’s add some Conditional Formatting so we can see the result of our work. With your 

mouse, highlight the entire image area inside the boundary box. 

• On the Home tab > Styles group, click the ‘Conditional Formatting’ dropdown and choose 

‘Highlight Cells’ and ‘Equal to’. Excel should select ‘2’ by default (the correct answer to Question 

#1), or you can type it in the ‘Equal to’ box. From the dropdown, choose ‘Custom Format’. 

• Click the ‘Fill’ tab and then click ‘More colors’ and go to the Custom tab. Look familiar? This is 

where we can use the HSL or RGB values we got from our image software. 
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• Note the ‘Color Model’ dropdown. The default is RGB, but if your image editing software only 

gave you HSL, you can choose that instead. Type in the values you want for your first color or 

click somewhere in the color field. Or just close this window and go back to Format Cells > Fill 

tab to choose a premixed background color. 

• Click ‘OK’ all the way back to your template. Now your cells should be shaded with your chosen 

color. 

• Continue using the Fill Handle to fill in the rest of the background cells. If you make a mistake, 

use CTRL + Z to undo it, or click in the cell and hit Delete. 

• When you’re ready to start on the next color, make a note of where your student will type the 

answer to Question #2. In our example, that will be Z5. 

• Click in your image wherever you want the second color and add the cell reference =$Z$5. Fill 

this wherever needed using the Fill Handle or CTRL + C and CTRL + V. 

• Now highlight the entire image again and go back to Conditional Formatting. Write a second rule 

where the value is equal to the correct answer to Question #2. 

• Choose a fill color or supply your own RGB or HSL value for one. 

• Repeat these steps throughout to finish building your image. 

• You may notice the black text looks a little tacky in the colored cells – and you can’t see it at all if 

your image contains black. Highlight the entire image and go up to Home > Font group. Click the 

dropdown next to the red ‘A’ and change the text color to white. 

Method #2 (Clean) 
• Start by filling in the correct answers to all the questions so you can see the results of your 

formatting work as you go. 

• Note the column and row where your student will type the answer to Question #1. In our 

example, the answer to goes in column Z, row 4. 

• On the Home tab > Styles group, click the Conditional Formatting dropdown and choose 

‘Manage Rules’. 



Page 7 of 10 
Copyright 2019 Chronicler’s Note 

www.ChroniclersNote.com 

• Make sure you select ‘This Worksheet’ from the ‘Show formatting rules for:’ dropdown. 

• Click ‘New Rule’ and ‘Use a formula to determine which cells to format.’ 

• Under ‘Format values where this formula is true’, type the following: =$Z$4= followed by the 

answer to question #1. This tells Excel to apply the conditional formatting ONLY if the student 

types the correct answer to question #1 in cell Z4. 

 

• Next we need to tell Excel what formatting to apply. In the same window, click the ‘Format’ 

button next to the preview. This will open the ‘Format Cells’ window. 

• Click the ‘Fill’ tab and then click ‘More colors’ and go to the Custom tab. Look familiar? This is 

where we can use the HSL or RGB values we got from our image software.  
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• Note the ‘Color Model’ dropdown. The default is RGB, but if your image editing software only 

gave you HSL, you can choose that instead. Type in the values you want for your first color. I 

recommend starting with the background color (I use a light bluish gray), because I find it easier 

to work from the outside in. 

• When you’ve selected your color, click ‘OK’ until you’re back at the ‘Edit Formatting Rule’ 

window. You should see your new color in the ‘Preview’ section. 

• Click ‘OK’ again to return to the ‘Conditional Formatting Rules Manager’ window. 

• Now we need to tell Excel which cells to apply the formatting to. Click into the ‘Applies to’ box 

and delete the default value (probably =$Z$4). 

• Type the = sign and hold down your CTRL key. Now with the mouse, start selecting the cells you 

want your color applied to. You can drag and select (recommended) or click individual cells. Just 

make sure to hold down CTRL. 

• This can take some trial and error, but don’t worry. If you click the wrong cell, just click it a 

second time (still holding down CTRL) to de-select it. 

• You should see the little ‘marching ants’ surrounding the selected cells while you work. When 

you’re done, click ‘Apply’. You should see the cells change color. 

• If you need to go back and edit your cell references, click the little up arrow next to the ‘Applies 

to’ box to see the full list of references. 
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• You’ll see a list of cell references like this: $B$2:$S$2 separated by commas. This reference style 

means that Excel will apply the formatting to all cells between B2 and S2. You can add a comma 

at the end and continue selecting cells. Or if you’re comfortable writing the cell references, you 

can just type them in the list. 
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• When you’re done applying cell references for this rule, click ‘New Rule’ to start with your next 

color. Repeat these steps (remember to change the cell reference in the formula to apply to 

Answer #2) until you’re done. 

• TIP #1: if working this way is too cumbersome, try applying your background color to the whole 

box, then close the Conditional Formatting tool. CTRL + Click any cells you want to ‘erase’ 

formatting from, then go to the Home tab > Editing Group, and select the Clear tool (looks like a 

pencil eraser). Choose ‘Clear Formats’. 

• TIP #2: Close the Conditional Formatting Manager. Click into a cell that already contains the 

formatting you like. Go to the Home tab > Clipboard group and click ‘Format Painter’. Now back 

in your image, click into a cell you would like to have the same formatting. Now the Conditional 

Formatting is applied without having to edit the rule. You can ‘paint’ formatting to multiple cells 

at once by holding drag-selecting with your mouse, either in the selection phase or the painting 

phase. Note – if you drag-select two cells when you select, your formatting will be painted to 

two cells. If you make a mistake, hit CTRL+Z to undo. 

• Depending on the complexity of your image, it may be helpful to move back and forth between 

these methods – apply some formatting, clean up with the Clear tool or paint with the Format 

Painter, switch to the next color for a minute, and then back again. Once you get the hang of it, 

all that’s required is patience. 

Finishing Up 
To test your work, delete all the answers and type them back in. You should see the colors disappear 

and then reappear. 

Congratulations! You’ve made your first interactive Excel Color by Number worksheet! If you have 

questions or problems, please don’t hesitate to contact me by emailing 

Chronicler@ChroniclersNote.com. 

Best regards, 

 

Brent 

mailto:Chronicler@ChroniclersNote.com

